AnsweredAssumed Answered

API error

Question asked by Ajay Desai on Nov 14, 2018
Latest reply on Nov 19, 2018 by Jeff Leggett

Hello,

 

I keep getting this error.

 

WARNING:root:../config/qualysAPIOnDemandConfig.conf permissions allows more than user access.
['Action,echo_request,title,Servicename,Port,IPAddress,username,password']
Traceback (most recent call last):
File "OracleAPI.py", line 40, in <module>
main()
File "OracleAPI.py", line 34, in main
xml_output=qgc.request(call,parameters)
File "/usr/local/lib/python2.7/dist-packages/qualysapi/connector.py", line 258, in request
url = self.url_api_version(api_version)
File "/usr/local/lib/python2.7/dist-packages/qualysapi/connector.py", line 136, in url_api_version
raise Exception("Unknown QualysGuard API Version Number (%s)" % (api_version,))
Exception: Unknown QualysGuard API Version Number (False)

 

 

Anyone know why?

 

Goal here is to make API calls to create Oracle Auth records. I had to hardcode the URL in the code as I kept getting a HTTP 400 error. 

 

 

Thanks,

Ajay

Outcomes