AnsweredAssumed Answered

Severe inconsistency in number of assets; affects VM, AssetView and TP

Question asked by Kiran Dhakal on Mar 23, 2018
Latest reply on Jun 5, 2018 by DMFezzaReed

Hello everyone,

I am perplexed by an inconsistency in number of assets in the Asset Groups, which has propagated to the AssetView and TP. I followed the following steps with the mentioned results:

 

- I recently removed a number of hosts (2k+) and also deleted all those hosts from a particular Asset Group, and emptied that Asset Group. 
- I then added 2243 hosts and again added them in the same Asset Group as above. 
- Then I scanned all those hosts, out of which 2101 were alive. I downloaded the report and then confirmed this number. 
- However, in the Asset Search, when I select the same Asset Group and don't specify any other attributes and search, then only 1393 hosts are shown. I believe the correct number should have been 2101.
- Also, in the Asset Search, when I select the tag corresponding to the same Asset Group, and don't specify any other attributes and search, again only 1393 hosts are shown. 
- And in Threat Protection module, in the Dashboard, when I filter the dashboard with the same tag, All Assets is shown to be 1470 in all the widgets. I believe, the correct number should have been 2101.
- And again in Threat Protection module, in the Dashboard, when no filter is applied, All Assets is shown to be 1619 assets. 


In conclusion, there are inconsistencies in the number of assets shown in different places, and this has severely affected the AssetView and Threat Protection modules.

 

Is there anything that I am missing?

Any help would be greatly appreciated.

 

assetgroups threatprotect asset_tags vulnerability management

Outcomes