AnsweredAssumed Answered

Associating users with WAS users?

Question asked by David Eriksson on Apr 11, 2017

I'm running into an issue with the fact that all users appear to have two different user ids. To use myself as an example, I have the user id 90091899 when looked up in the VM module, but 4985012 when viewed in the Administration module, presumably associated to WAS.

 

What I'm trying to do is to basically fetch all our webapps with the name of the person who created them. The webapp search API returns me the "Owner id", which I then try to associate with a user returned from the old User API (/msp/user_list.php), but due to the mismatching described above, this obviously fails.

 

The straight-forward solution here would be to fetch the full webapp details for each webapp, but when reaching our amount of webapps, this becomes an issue both with potential quota of calls, as well as the time it would take to send and process them.

 

I had a similar issue with getting the tags associated to each webapp, which I managed to get around by doing a single call to the Assets API and matching those to the webapp based on name & creation date.

 

Overall, the User API is obviously very old, and I have not seen any kinds of similar calls made available in the more recent APIs. The only solution I see right now is to keep a local copy of the users, and query the webapp API for full details only if this is missing, but that seems needlessly complicated. Any suggestions?

Outcomes