AnsweredAssumed Answered

SSLProtocol: Illegal protocol 'TLSv1.2'

Question asked by Rifky Ramadhana on Mar 14, 2016
Latest reply on Sep 20, 2016 by Douglas Landau

Hi,

I use

- Red Hat Enterprise Linux Server release 6.4 (Santiago)

- Apache/2.4.17 (Unix)

- OpenSSL 1.0.0-fips 29 Mar 2010

 

I want to enable TLSv1.2, so i did upgrade OpenSLL into OpenSSL 1.0.1e-fips 11 Feb 2013

 

And then change /usr/local/apache2/conf/extra/httpd-ssl.conf with this command:

#SSLProtocol all -SSLv3

#SSLProxyProtocol all -SSLv3

SSLProtocol -all +TLSv1.2

SSLProxyProtocol -all +TLSv1.2

 

But when i did restart httpd there is error:

restart httpd : AH00526: Syntax error on line 83 of /usr/local/apache2/conf/extra/httpd-ssl.conf:

SSLProtocol: Illegal protocol 'TLSv1.2'

 

Please help me how to solve this issue?

IMO, Apache/2.4.17 (Unix) and penSSL 1.0.1e-fips 11 Feb 2013

already support TLSv1.2

 

Thank You

Outcomes