AnsweredAssumed Answered

Unable to add schedule scan for asset group v2 api

Question asked by Todd Merritt on Oct 2, 2015
Latest reply on Dec 16, 2015 by Kate-o

I'm trying to add a scheduled scan for an asset group.  It works fine through the gui, but when I try it via the v2 api I get

 

    <CODE>1904</CODE>

    <TEXT>none of the specified IPs are eligible for Vulnerability Management scanning.</TEXT>

 

It seems like maybe there were some issues with the v1 api and asset groups but I couldn't find any reference to this error with the v2 api.  The query I'm using is

 

action=create&active=1&scan_title=foo_scan&target_from=assets&asset_group_ids=${ag_id}&occurrence=monthly&frequency_months=3&day_of_month=1&start_hour=${START_HR}&start_minute=${START_MIN}&time_zone_code=US-AZ&observe_dst=no&option_title=Initial+Options&default_scanner=1

 

Can somebody point out what I'm missing?

 

TIA,

Todd

Outcomes