AnsweredAssumed Answered

Enabling SPDY on Apache 2.4

Question asked by Bob Watson on Dec 16, 2014
Latest reply on Feb 16, 2015 by David Favor

I have just run a recent SSL Labs test against my server and I noticed this:

 

Next Protocol Negotiation (NPN) No


I run FreeBSD 10.1 with Apache 2.4.10 and OpenSSL 1.0.1j. I also ran a test at:

 

SPDYCheck: Testing Websites for SPDY Support

 

and it says that:

 

Missing NPN Extension in SSL/TLS Handshake

Sorry, but this server is not including an NPN Entension during the SSL/TLS handshake. The NPN Extension is an additional part of the SSL/TLS ServerHello message which allows web servers to tell browsers they support additional protocols, like SPDY. SSL/TLS servers that don't use send the NPN Extension cannot use SPDY because they have no way to tell the browser to use SPDY instead of HTTP.

 

SPDY Capable Server Detected!

Well awesome! This SSL/TLS web server is identifying itself as Apache/2.4.10 (FreeBSD) OpenSSL/1.0.1j. This is a SPDY capable web server! Go check your server for modules or newer versions which have SPDY support enabled.

 

So how do I enable this NPN Extension on my server? And how do I then enable SPDY after that?

Outcomes