AnsweredAssumed Answered

Why can't I connect to specific TLS 1.2 server with TLS 1.2?

Question asked by BoerenkoolMetWorst on Oct 26, 2014
Latest reply on Oct 29, 2014 by Ivan Ristić

I can't connect to this banking site that supports TLS 1.2 with TLS 1.2:
https://www.ssllabs.com/ssltest/analyze.html?d=https://bankieren.triodos.nl/

 

When I use IE 11 it shows the connection uses TLS 1.0, even though TLS 1.1 and 1.2 are enabled in IE. When I disable TLS 1.0 in IE, I'm unable to connect.
Using Firefox 33, it is also impossible to connect with TLS 1.0 disabled.

 

Is there something wrong with this servers configuration?

Outcomes