Patric Fox

Scanner Appliance not available for sub-user's in WAS

Discussion created by Patric Fox Employee on May 15, 2013

Just an FYI for everyone using internal scanner appliances for Web App Scanning:

 

In order for a sub-user (specifically user's within a business unit) to have access to a scanner appliance in the WAS module, they must first be granted access to the appliance via an Asset Tag.  I've included step-by-step instructions below for setting up and enabling this.

 

To do this, you will need to do the following:

Create the Tag:

1. Login to QualysGuard

2. Using the module selector in the top left, choose Asset

3. Once in the asset module, you'll need to create a tag for the scanner appliance that the user needs access to.

4. Click on the "Tags" tab

          a. Click "Create Tag"

          b. Name: (In this example) ScannerAppliance For WAS

          c. Click Continue

          d. Change the "No Dynamic Rule" drop down to "Asset Name Contains"

          e. Enter the name of the scanner appliance being used in the Regular Expression field.

          f. click checkbox for "Re-evaluate rule on save"

          g. click continue, then finish.

5. If you wait 30-60 seconds you should be able to click on the tag after the save and see 1 asset assigned to it (the scanner appliance).

 

Assign the Tag:

6. Now that the tag exists, we need to assign it to the user.

7. Click the module picker again in the top left and choose "Admin"

8. Mouse over the user that needs access and from the Quick Action menu, choose "Add tags to scope"

9. On the new window, find the ScannerAppliance for WAS tag that we created and click on it, you should see it move to the right hand column.

10. Click save, have the user log out and log back in and they should now see the scanner appliance available in the WAS module.

Outcomes