Parag Baxi

How to extend Archer's 5 minute timeout

Discussion created by Parag Baxi on Jan 11, 2013
Latest reply on Jan 11, 2013 by downinej

If you have Archer 5.3p1 or greater, you may be scratching your head at why your Qualys calls are timing out. The issue is that there was a hardcoded time limit within Archer's code. As a previous Qualys community thread had noted, Archer was putting out a fix for this issue.

 

The good news is that the Archer timeout hotfix has been released! Unfortunately, the fix is not well documented. Working with an Archer engineer, we were able to figure out how to configure the timeout.

 

Follow the instructions below to extend the 5 minute timeout to whatever you would like:

  1. Login to Archer with admin credentials.
  2. Open the "Data Feed Manager".
  3. Select "Source Definition" tab.
  4. Select "Tokens" subtab.
  5. Click "Add New" to add a new token to overwrite a default setting.
  6. The name of the new token is HTTPReadWriteTimeout. The value is counted in milliseconds.

 

Here is how the configuration should appear if you would like a timeout for about 28 hours:

image003.jpg

 

Now, I know what you're thinking, "let's set it to over 9000 hours"! Well, we tried it, and it didn't work. If you set the timeout value too high like 99999999999, this will cause what is most likely a buffer overflow in Archer. There is no error, but the data is never processed by Archer.

 

Hope this helps!

Outcomes