Skip navigation
Previous Next

API Notifications

December 2010
0

A new update of QualysGuard® version 6.16 will be available in production on Thursday, January 6th 2011 for the US platform, and on Thursday, January 13th 2011 for the EU platform. This release is completely transparent to users and will require no scheduled downtime. The release will occur between 12 PM PST (20:00 GMT) and 6 PM PST (02:00 AM GMT next day).

 

 

QualysGuard 6.16 includes the following API enhancements:

Unix Authentication API Updates for PowerBroker Support

Note: Support for BeyondTrust PowerBroker is deprecated as of July 2012. The API will continue to be available to existing customers already using it, but will not be available for new implementations.

 

For QualysGuard 6.16 updates were made to the Unix scan authentication API to add support for PowerBroker, a root delegation tool. This API allows you to manage Unix authentication records in your QualysGuard account. With this QualysGuard release, users can choose to use PowerBroker, instead of Sudo, by selecting this option within their Unix authentication records.

 

The /api/2.0/fo/auth/unix resource is used to manage Unix authentication records. For this release changes were made to input parameters used to add or edit a Unix record (action=create and action=update) and the Unix authentication list DTD (auth_unix_list_output.dtd), as described in the sections below.

 

New Malware Correlation Information

With this release, QualysGuard correlates malware information with vulnerabilities in the Qualys KnowledgeBase when malware threats for vulnerabilities are published within the Trend Micro Threat Encyclopedia. This correlation will allow QualysGuard users to prioritize and filter vulnerabilities so that they can get actionable information to administrators for remediation of vulnerabilities that can lead to malware infections.

 

There are 3 important updates to report DTDs to support this new XML structure:

  • New <MALWARE> element and its child elements identify malware correlation information.
  • Child elements of the existing <EXPLOITABILITY> element have new, shorter names.
  • New <CORRELATION> element is the parent element for the <EXPLOITABILITY> element and the new <MALWARE> element.

 

 

Full details are available about these XML changes within the Qualys community at: https://community.qualys.com/docs/DOC-1934

 

API release notes will be available to customers from within the Resources section of your QualysGuard account.

 

To receive more information on QualysGuard 6.16, please visit Qualys Community or contact your Technical Account Manager or Qualys' Technical Support Department at support@qualys.com.

 

Qualys Notifications are moving to self-subscription on the Qualys Community.  To continue receiving notifications like this one please register at:

 

We thank you for your continued support and look forward to continuously improving our services.

 

Eric Perraudeau

Product Manager for API and Integrations

eperraudeau@qualys.com

+1 650 801 7750

Bookmarked By (0)

Actions